Knowledge base

Asset 32

Beaming example IPv6 Cisco broadband router configuration

Posted on 19 October 2017 by Beaming Support

Example IPv6 Cisco broadband router configuration

The following configuration shows the basic commands to add IPv6 to your Cisco broadband router. It is assumed that you are already competent with configuring Cisco routers and that you can integrate the configuration below into your own existing router configuration. It is provided as-is and care should be taken to ensure that you adequately secure your devices for HTTP / SSH and Telnet to the VTY lines. Remember that these will all need securing too once IPv6 is enabled as your existing IPv4 ACL’s will offer no protection!

This example is from a Cisco 887VA router using IOS 15.6.
ipv6 source-route
ipv6 unicast-routing
ipv6 cef
ipv6 inspect name IPV6FIREWALL tcp timeout 60
ipv6 inspect name IPV6FIREWALL udp timeout 60
ipv6 inspect name IPV6FIREWALL icmp timeout 60
ipv6 dhcp pool IPV6DHCP
dns-server 2A00:1CD8:BEA:200::1 !Beaming DNS Server 1
dns-server 2A00:1CD8:BEA:200::2 !Beaming DNS Server 2
!
interface Vlan1
ipv6 address BEAMING-PD ::2:0:0:0:1/64
ipv6 enable
ipv6 nd other-config-flag
ipv6 nd router-preference High
ipv6 tcp adjust-mss 1440
ipv6 dhcp server IPV6DHCP
ipv6 inspect IPV6FIREWALL in
ipv6 traffic-filter IPV6-LAN-TO-WAN in
ipv6 virtual-reassembly in
!
interface Dialer100
ipv6 address dhcp rapid-commit
ipv6 address FE80::1 link-local
ipv6 address BEAMING-PD ::1:0:0:0:1/64
ipv6 enable
ipv6 mtu 1508
ipv6 tcp adjust-mss 1440
ipv6 dhcp client pd BEAMING-PD
ipv6 inspect IPV6FIREWALL in
ipv6 traffic-filter IPV6-WAN-TO-LAN in
ipv6 virtual-reassembly in
!
ipv6 route ::/0 Dialer100
!
ipv6 access-list IPV6-LAN-TO-WAN
permit icmp any any nd-na
permit icmp any any nd-ns
permit ipv6 any any
!
ipv6 access-list IPV6-WAN-TO-LAN
permit udp FE80::/10 eq 547 any eq 546
permit icmp FE80::/10 any
permit icmp any any echo-reply
permit icmp any any echo-request
permit icmp any any no-route
permit icmp any any packet-too-big
permit icmp any any hop-limit
permit icmp any any header
permit icmp any any next-header
permit icmp any any parameter-option
permit icmp any any time-exceeded
deny ipv6 any any

Find out more about IPv6 in our article here.

Asset 16

We answer real questions asked by businesses

From simple cyber security solutions to O365 migrations and everything in between. Take a look at our knowledge base and benefit from our expertise.

Get the best of Beaming straight to your inbox

Our monthly email bulletin updates you on the best tech dedicated to keeping you online, how to make the most of your current connectivity and business tips to free up more of your time.

  • This field is for validation purposes and should be left unchanged.